レガシーなコード達 PHPで色々やってるアラフォー

PHPer歴10年ですが、まだモダンからはかけ離れた開発をしていますので、辞めたいです。

Vagrantで作る旧Verが入ってるサーバ。それ必要?

php5.4とか、mysql5.0とか古いバージョンで動いていたプログラムを最新バージョンに移植しないといけない時に、本番で稼働しているサーバに別ディレクトリで開発環境立てるのも良いが、Vagrantで作ることも考える。

 

ただ、ここで注意したいのは、目的を見失うこと。

 

旧バージョンを新バージョンに書き換えて、稼働させる

 

そのための最短距離を選ぶべきだ。

実務で作ることは 納期があって

そのために必要な距離を算出しなければならない。

 

ましてや自分みたいにサーバ構築が不慣れな場合、多くの時間を構築に要する。

やるべきはプログラムの書き換えであり、サーバ構築ではないということ。

 

今後の運用のためにもサーバ構築が必要なのは、新バージョンが動く環境であり、旧バージョンではないので、無理してサーバを作る必要はない。

 

必要ないのだ。